Общая структура

Общая структура программы

Полная версия программы состоит из трех аналитических блоков

  • Арбитраж и Мультиарбитраж (радар) – работа с синтетической облигацией (акции+фьючерс, фьючерс+фьючерс)
  • Хеджер – поиск наименее рискованных комбинаций (акции+опцион)
  • Спекулянт – поиск наиболее доходных комбинаций из опционов.
И нескольких вспомогательных
  • Калькулятор опционов – вычисление и мониторинг характеристик, связанных с опционами
  • Минипортфель - вычисление характеристик на текущую и заданные даты для набора позиций на один базисный актив (так называемый минипортфель)
  • Комбинации - подбор комбинированных позиций из опционов (комбинаций/вертикальных спредов), прибыльных при заданном сценарии поведения рынка: рост, падение, резкое изменение или боковик.
  • Автопрогноз – анализ/прогноз исторических данных (цен, волатильности).
  • Корреляции - подсчет корреляций для исторических данных (цен, доходностей).

Версия-лайт состоит из двух блоков

  • Калькулятор опционов - вычисление и мониторинг характеристик, связанных с опционами
  • Комбинации - подбор комбинированных позиций из опционов (комбинаций/вертикальных спредов), прибыльных при заданном сценарии поведения рынка: рост, падение, резкое изменение или боковик.

Все вычисления (за исключением блоков "Автопрогноз" и "Корреляции") проводятся на основе котировок на покупку и продажу. Есть возможность проводить вычисления как на основе лучших котировок, так и на основе стакана котировок заданной глубины (это относится к блокам "Хеджер", "Спекулянт", "Минипортфель" и "Калькулятор опционов"). Так как для одного базисного актива, с учетом опционов, понадобится загрузка до 30 стаканов, то процесс загрузки может занять некоторое (при выделенной линии небольшое, а при dialup доступе - несколько минут) время. Поэтому загрузка стаканов для базисного актива происходит в тот момент, когда впервые после запуска программы возникает необходимость в загрузке стаканов данного базисного актива. При заданной глубине стакана, равной 1 (устанавливается в общих параметрах программы), лучшая котировка совпадает со средневзвешенной. Заметим, что получение лучшей котировки не требует загрузки стакана, однако при этом информация об ее объеме отсутствует.

Инструменты, с которыми работает программа, задаются в файле TrinityNZ.ini. На данный момент котировки акций можно получать только с ММВБ. В файле TrinityNZ.ini также задается число акций, составляющих специфицированный биржей фьючерсный контракт (параметр LotFut). Такое число акций будем называть контрактным лотом.

Пользователь может открыть сколько угодно окон как разных, так и одного типа (т.е. из одного блока) для разных базисных активов, разных дат, разных типов комбинаций инструментов. Например, в блоке "Хеджер" можно открыть одно окно для комбинации (акции+покупка опциона-пут) для РАО ЕЭС на дату истечения. А можно открыть окно для комбинации (акции+продажа опциона-колл) для ЛУКОЙЛ на 1 сентября.

Все опции в программе делятся на общие, относящиеся ко всем блоками и окнам (их можно изменить с помощью Блоки|Параметры) и на опции, относящиеся ко всем окнам одного блока. Например, при активном окне из блока "Хеджер" появляется пункт меню Хеджер|Настройки, в котором можно менять значения параметров данного блока. Часть параметров блока имеет разное значение для разных базисных активов. Для блоков "Хеджер" и "Спекулянт" опции общие. Опции блока "Комбинации" - общие с блоком "Калькулятор опционов". Опции блока "Минипортфель", относящиеся к текущей дате (текущая волатильность), - общие с блоком "Калькулятор опционов". Опции блока "Минипортфель", относящиеся к ожидаемым на заданную дату характеристикам, - общие с блоками "Хеджер" и "Спекулянт" . Опции блока "Арбитраж" - индивидуальные для каждого окна блока.

См. также:

  • Теоретическая модель
  • Общие параметры
  • Задание модели поведения цены
  • Управление расположением окон
  • Возможности графики
  • Возможности таблиц
  • Параметры связи


Теоретическая модель

При вычислениях используется ценовая модель геометрического броуновского движения, в которой приращения логарифмов цен независимы и имеют нормальное распределение. В блоках "Хеджер", "Спекулянт" и "Минипортфель" предполагается, что опционы предъявляются только в момент экспирации (в момент истечения их срока), что соответствует опционам европейского типа. Для оценивания их справедливой цены используется или модель Блека-Шоулса с ценой 1 контрактного лота акций (т.е. числа акций, составляющих специфицированный биржей фьючерсный контракт) в качестве цены базисного актива или модель Блека с ценой фьючерса в качестве цены базисного актива. В блоке "Калькулятор опционов" есть возможность получать характеристики опционов американского типа на основе биномиальной модели.

Заметим, что для колл-опционов все характеристики не зависят от того, какого типа опционы, американского или европейского. Поэтому вычисления по моделям Блека-Шоулса и Блека дают точные результаты и для опционов американского типа. Для пут-опционов американского типа эти модели дают немного завышенные значения для справедливой цены опционов и немного заниженные значения для подразумеваемой волатильности. Однако разница небольшая и чем меньше время до экспирации опциона, тем она меньше. Приближенные вычисления по биномиальной модели дают ошибку вычислений, сравнимую с этой разницей и с опционными спредами, которые существуют на данный момент на рынке. Таким образом, вычисления по модели Блека/Блека-Шоулса дают вполне адекватные результаты независимо от типа опциона.


Общие параметры

Общие параметры можно поменять с помощью меню Блоки|Параметры. Там можно установить

  1. значение безрисковой ставки на сегодняшний день (например, 0.1, что соответствует 10% годовых),
  2. база опциона (если выбрано акции, то вычисления происходят на основе модели Блека-Шоулса, где в качестве базисного актива подставляется цена 1 контрактного лота акций; если выбрано фьючерс, то вычисления происходят на основе модели Блека, где в качестве базисного актива подставляется цена фьючерса),
  3. тип дисконтирования (рекомендуется задать Непрерывный),
  4. скорость/точность вычислений: так как в блоках для хеджера и спекулянта, а также в блоке Минипортфель и калькуляторе опционов производятся численные (приближенные) вычисления, то есть возможность выбрать соотношение между точностью и скоростью вычислений в зависимости от характеристик компьютера пользователя. Стандартный режим - Средние. При мощном компьютере рекомендуется выбрать Точные вычисления,
  5. режим просмотра результатов: чтобы не мешали лишние дополнительные столбцы таблиц, рекомендуется установить Простой режим просмотра (на данный момент, действует только на блок для спекулянта),
  6. используемая глубина стакана котировок для вычисления средневзвешенных по объемам цен предложений на продажу и на покупку.

На данный момент мы описываем только результаты в Простом режиме просмотра.


Задание модели поведения цены

Для вычисления характеристик портфеля (т.е. рассматриваемой комбинации в блоках для хеджера и для спекулянта, а также портфеля в блоке Минипортфель) нужно знать распределение цены 1 контрактного лота акций, составляющих базисный актив портфеля, в интересующий пользователя момент t. Это распределение можно задать двумя способами (напомним, что 1 контрактный лот - это число акций, составляющих специфицированный биржей фьючесный контракт).

  1. задаются ожидаемая средняя скорость роста цен акций (в пересчете на год), годовая волатильность (предполагается неизменной). На основе этих характеристик и модели геометрического броуновского движения определяется распределение цены в момент времени t.
  2. предсказание значения цены 1 контрактного лота акции в момент времени t с помощью среднего значения и стандартного отклонения предсказания (эти характеристики можно трактовать как наиболее вероятное значение + ошибка предсказания; в свою очередь, ошибка предсказания – это такая величина, что с вероятностью 0.95 прогноз цены лежит в пределах среднее значение плюс/минус две ошибки). Например, если значение цены = 8000, ошибка = 100, то цена с вероятностью 0.95 будет лежать в пределах от 7800 до 8200.

Для определения характеристик портфеля в будущий момент времени t (для вычисления справедливой цены опционов в момент времени t) нужно также знать значения волатильности в момент времени t и значение безрисковой ставки в момент времени t.


Управление расположением окон

Рабочее окно программы с помощью закладок может быть разделено на несколько рабочих столов. Расположение окон на рабочем столе можно менять вручную, а также через меню Окна.

При первом запуске программы образуется один рабочий стол "Основной". Управлять закладками/рабочими столами (добавлять, переименовывать, удалять) можно через контекстное меню, вызываемое по щелчку правой кнопки мыши над ярлыком одной из закладок.

Созданные закладки и расположение окон на рабочих столах сохраняются при последующих запусках программы.

Можно иметь различные конфигурации рабочих столов, сохраняя с помощью контекстного меню их на диск и затем загружая более удобную в данный момент конфигурацию.


Возможности графики

На данный момент реализованы след. возможности:

  1. По двойному щелчку выдаются координаты точки
  2. При нажатой клавише SHIFT с помощью курсора мыши (при нажатой левой кнопки) можно выделять область графика (с левого верхнего угла к правому нижнему) и увеличивать ее. Для увеличения масштаба по вертикали надо двигать курсор вниз, для увеличения масштаба по горизонтали – двигать вправо. Обратное движение по горизонтали или вертикали приводит к восстановлению исходного масштаба. Далее выделенную область можно сдвигать или с помощью скроллинга или с помощью перетаскивания мышью.
  3. При нажатой клавише ALT курсор меняется и состоит из горизонтальной и вертикальной пунктирных линий

Контекстное меню Сохранить данные позволяет сохранить значения, по которым был построен график, в файл формата CSV (comma separated values - текстовый формат, являющийся также форматом Excel)

Контекстное меню Копировать позволяет скопировать график в формате, удобном для последующей вставки в документ WORD.


Возможности таблиц

При работе с таблицами есть возможность использовать контекстное меню, которое позволяет

  1. копировать выделенные ячейки (Копировать);
  2. копировать выделенные ячейки вместе с названиями строк, столбцов и общим названием таблицы (Копировать с заголовками);
  3. сохранять таблицу в текстовый файл (Сохранить);
Заметим, что выбрав в контекстном меню Выделить все, затем Копировать с заголовкам, и сделав вставку в Excel файл, пользователь получает возможность быстро сохранить результаты в Excel файле.

При создании таблицы ширина столбцов берется по умолчанию, но для каждой созданной таблицы пользователь может поменять ширину каждого столбца и все изменения запомнятся.

В блоках "Хеджер" и "Спекулянт" щелчком по заголовку столбца таблицы с результатами можно упорядочивать строки по значениям выбранного столбца. Повторный щелчок меняет направление упорядочивания на противоположное.

В блоках "Спекулянт" и "Минипортфель" реализована возможность по выделенной строке таблицы (в блоке "Минипортфель" - по выделенной строке нижней таблицы) получать дополнительную графическую информацию по пункту контекстного меню График.


Параметры связи

Программа работает на основе доступа, предоставляемого торговой системой NetInvestor.

Так как при одних и тех же параметрах доступа (имя и пароль) возможен только один вход в систему, то программа TrinityNZ и NetInvestor не могут работать одновременно при одних и тех же параметрах доступа.

Данные, которые должны быть установлены в качестве параметров связи (Связь|Параметры) , предоставляются торговой системой NetInvestor. Каждый зарегистрированный пользователь программы TrinityNZ получает все необходимые данные для доступа к котировкам тороговой системы NetInvestor через программу TrinityNZ.

Ответы на вопросы, которые могут возникнуть при соединении, можно найти в FAQ NetInvestor.

При не очень хорошей связи (в частности, dial-up) параметр Timeout рекомендуется увеличить (например, до 60000 мс).


Блок для арбитражера

Блок для арбитража

Описание наполнения

Блок служит для арбитража с помощью покупки или продажи синтетической облигации. Рассматриваются синтетические облигации двух видов (на примере покупки):

  1. «покупка 1 контрактного лота акции» + «продажа 1 фьючерса»
  2. «покупка 1 фьючерса» + «продажа 1 фьючерса с более дальним сроком исполнения»
Надстройкой к этому блоку, позволяющей мониторить сразу все синтетические облигации на один базисный актив, является блок Мультиарбитраж.

Опишем подробно стандартный арбитраж с участием акции и фьючерса. Тогда «купить облигацию» означает «купить акции и продать фьючерс», продать облигацию означает «продать акции и купить фьючерс».

Под 1 контрактным лотом акций понимается число акций, составляющих специфицированный биржей фьючерсный контракт. Например, для РАО ЕЭС один контрактный лот равен 1000.

Гарантированная доходность от синт.облигации в момент погашения (т.е. в момент истечения фьючерса) вычисляется как (цена фьючерса-цена акций)/цена акций. Так как существует спред между ценой покупки и ценой продажи, то при покупке комбинации доходность синт. облигации вычисляется как (FS – AB)/AB, где FS – цена, по которой можно продать фьючерс (котировка фьючерса на покупку), AS – цена, по которой можно купить 1 контрактный лот акций (котировка акций на продажу). Назовем эту доходность продаваемой (т.е. доходность, которую, на основе котировок, нам согласны продать). Соответственно, при продаже синт. облигации оценка доходности (так сказать, покупаемой доходности) вычисляется как (FB– AS)/AS. Из-за спреда покупаемая доходность больше продаваемой.

С точностью до риска, состоящего в невыполнении биржей своих обязательств, среднюю доходность от синт. облигации можно рассматривать как оценку безрисковой ставки на данный момент.

Если мы хотим спекулировать синтетической облигацией, то идея состоит в том, что доходность синтетической облигации колеблется вокруг безрисковой ставки, которую можно рассматривать как постоянную величину (по крайней мере, эта величина, если и не постоянная, то медленно меняется во времени). Будем исходить из след. постулата: если в какой-то момент цена синт. облигации была выше оценки безрисковой ставки на основе синт. облигации, то она обязательно в будущем станет меньше. Если цена базисного актива за это время не слишком сильно выросла, то таким образом можно получить прибыль.

С учетом данного постулата, арбитражеру-спекулянту выгодно покупать синт.облигацию, если продаваемая доходность больше оценки безрисковой ставки, получаемой с помощью усреднения (по некоторому промежутку времени) покупаемой доходности.

Результатом работы программы является следующий график:

  • при покупке синт. облигации рисуется линия с зелеными маркерами, обозначающая доходность (в пересчете на год), заложенную в синт. облигацию, которую у нас есть возможность купить - продаваемая доходность. Серая линия изображает среднюю покупаемую доходность за заданный при образовании блока период времени.
  • при продаже синт. облигации заложенная в нее покупаемая доходность в пересчете на год изображается с обратным знаком линией с красными маркерами. Средняя продаваемая доходность изображается также с обратным знаком.

Для более компактного изображения результата блока реализован вид окна в виде "Градусника". Индикатор градусника показывает расположение линии продаваемой или покупаемой доходности в данный момент. Для переключения между двумя представлениями окна служит кнопка >> в правом нижнем углу окна. Также переключение вида активного окна можно сделать с помощью меню Арбитраж|График или Арбитраж|Градусник соответственно.

Сигналы

В программе заложена возможность подавать сигналы (цветной квадратик внизу окна, надпись о том, что сигнализируется, и, по желанию, звуковой сигнал). Сигнал подается, если заложенная в облигацию доходность больше заданного порога. Звуковой сигнал проигрывается при первом превышении порога. Снова звуковой сигнал поступает только если доходность сначала спустится ниже порога, а потом снова станет выше.

Настройки

Кроме числа точек на графике, все остальные настройки индивидуальны для каждого окна блока. Это означает, что изменение настроек с помощью меню Арбитраж|Настройки в активном окне никак не влияет на вид/поведение другого окна Блока для арбитражеров. Соответственно, измененные настройки при закрывании окна пропадают.

При образовании окна блока через меню Блоки|Арбитраж первоначальные настройки зафиксированы в программе. Если окно Блока для арбитражера создается на базе окна блока Мультиарбитраж, то настройки берутся из настроек Мультиарбитража.

Работа с блоком «Арбитраж»

  1. Запустите программу.
  2. Для работы в on-line используйте Связь|Соединиться (предполагается, что установки для соединения уже были настроены ранее с помощью Связь|Параметры)
  3. Выберите Блоки|Арбитраж.
  4. В появившемся окне выберите базисный актив (например, РАО ЕЭС), в качестве первого инструмента - акции, в качестве второго - вид фьючерса, затем покупку или продажу (например, покупку), а также период, по которому строить оценку покупаемой безрисковой ставки (по умолчанию – 7 дней (неделя)). Появится окно из блока «Арбитраж» с выбранными установками.
  5. Можно проделать предыдущий пункт еще раз, выбрав те же установки, но другой вид фьючерса.
  6. С помощью меню Окна|Рядами можно сделать так, чтобы оба открытых окна были видны.
  7. Выбрать Арбитраж|Настройки. На странице Вид лучше убрать галочку с "Не ограничивать" (если она там стояла) и поставить максимальное число точек на графике, равное, например, 200.
  8. Все, можно разглядывать результаты. Но если данных по истории еще не было накоплено, то первое время линия средней доходности, заложенной в синт.облигацию, может прыгать.
  9. Пока программа работает, данные о средних безрисковых ставках, заложенных в синт. облигации "акции+фьючерс", собираются и при выходе их программы (а также раз в час) сохраняются в файле AvArbitr.xls. За последние два дня хранятся минутные средние, за последнюю неделю – часовые, и за последний год – дневные.

Заметим, что при формировании синтетической комбинации "фьючерс1+фьючерс2" считается, что первый фьючерс истекает раньше, чем второй. Поэтому при любом задании параметров блока «Арбитраж» в качестве первого фьючерса выбирается тот из 1-го и 2-го инструментов, у которого более ранний срок истечения.

Также отметим, что для арбитража "фьючерс-фьючерс" средняя безрисковая ставка не вычисляется и поэтому рисуется просто горизонтальная линия, соответствующая установленному в программе значению безрисковой ставки.

Особенности арбитража фьючерс-фьючерс

При покупке синт.облигации мы покупаем гарантированную доходность за счет одновременной покупки акций и отложенной продажи этих же акций по более высокой цене в виде продажи фьючерса. Так как продажа происходит только в момент истечения фьючерса, то наш гарантированный выигрыш получается отложенным до момента истечения фьючерса.

При покупке синт.облигации из двух фьючерсов мы также покупаем и продаем одни и те же акции, только покупка акций отложена до момента истечения купленного фьючерса с более близкой датой исполнения, а продажа акций отложена до момента истечения проданного фьючерса с более далекой датой исполнения. Если не учитывать гарантийного обеспечения, то в данном случае вкладывать в покупку деньги нужно только в момент истечения первого, купленного, фьючерса. В этот момент мы покупаем акции по цене первого фьючерса. А реализуется доходность в момент истечения второго, проданного, фьючерса. Поэтому формально доходность можно рассчитывать по формуле (F2S -F1B)/F1B из расчета на время между датами истечения фьючерсов. Вообще, вариант акции+фьючерс является частным случаем варианта (фьючерс+фьючерс), если приравнивать контрактный лот акций к фьючерсу с текущей датой истечения.

В любом случае, при приобретении синтетической облигации размер доходности, при которой она считается выгодной, рассчитывается исходя из конкретной ситуации, с учетом ГО, условий приема акций в залог, рисков, связанных с отложенным моментом получения прибыли, и т.д.


Мультиарбитраж (арбитражный радар)

Описание наполнения

Этот блок является надстройкой к Блоку для арбитражера и служит для мониторинга сразу всех синтетических облигаций на один базисный актив.

При открытии блока определяются все фьючерсы, которые существуют на выбранный базисный актив, и строятся всевозможные синтетические облигации на пары "акция-фьючерс" и "фьючерс-фьючерс". Для каждой синтетической облигации рассматриваются как ее покупка, так и ее продажа. Напомним (на примере пары "акция-фьючерс") , что доходности выдаются в пересчете на год, при покупке облигации доходность синт. облигации вычисляется на основе (FS - AB)/AB, где FS - цена, по которой можно продать фьючерс (котировка фьючерса на покупку), AS - цена, по которой можно купить 1 контрактный лот акций (котировка акций на продажу). Соответственно, при продаже синт. облигации оценка доходности вычисляется на основе (FB- AS)/AS и результат выдается с минусом; поэтому положительное значение соответствует так называемой ситуации бэквардейшен, когда фьючерс стоит дешевле контрактного лота акций. Таким образом, в обоих случаях, чем больше значение, тем лучше. Причем положительное значение, с точностью до издержек, означает гарантированное значение доходности.

Каждая пара инструментов отображается в виде "Градусника", показывающего ее доходность. Шкала изображения регулируется с помощью задания максимума и минимума. Эти значения можно поменять с помощью меню Мультиарбитраж|Настройки.

Сигналы

Система сигналов в блоке Мультиарбитраж очень важна, так как основное назначение блока - это мониторинг. Сигналы подаются при превышении годовой доходностью, заложенной в синетическую облигацию, заданного порога. Этот порог можно задавать через меню Мультиарбитраж|Настройки, а также регулировать с помощью перемещения мышью или клавишами вверх-вниз указателя ползунка, расположенного слева в окне блока.

В программе заложена возможность подавать сигналы несколькими способами: цветной квадратик рядом с "градусником", звуковой сигнал, выделение красным цветом ярлыка рабочего стола (если он не является активным), на котором расположено окно Мультиарбитража, подающего сигнал, а также мигание кнопки программы TrinityNZ на панели задач, если программа является неактивной. Цвет и звук можно задать посредством Мультиарбитраж|Настройки.

Цветной квадратик отображается все время, пока доходность превышает заданный порог. Звуковой сигнал проигрывается при первом превышении порога. Снова звуковой сигнал поступает только если доходность сначала спустится ниже порога, а потом снова станет выше. Выделение ярлыка рабочего стола при поступлении сигнала прекращается при переходе на выделенный рабочий стол. Аналогично, мигание кнопки программы на панели задач прекращается при активизации программы. Повторное выделение ярлыка рабочего стола и кнопки программы на панели задач (в случае неактивности соответствующих компонент) происходит только если доходность сначала спустится ниже порога, а потом снова станет выше.

В блоке реализована возможность управлять подачей сигналов (это не распространяется на появление цветного квадратика при сигнале). Для каждой пары можно индивидуально отключить/включить подачу сигнала с помощью контекстного меню над соответствующим "градусником". Для всех пар окна блока (покупка и продажа отдельно) можно одновременно отключить/подключить подачу сигналов либо с помощью меню Мультиарбитраж|Настройки, либо с помощью элемента управления "Сигнал" слева (поставить или снять галочку).

Чтобы получить более подробную информацию о синтетической комбинации, можно с помощью либо контекстного меню, либо кнопки с >> , либо просто двойным щелчком мыши на "Градуснике" перейти в окно Блока для арбитражера , соответствующее данной синтетической комбинации.

Настройки

Опции блока Мультиарбитраж, которые можно менять в настройках блока (кроме отключения/подключения сигналов), относятся ко всем окнам Мультиарбитража на данный базисный актив. Они запоминаются и остаются действующими при следующих запусках программы. Окна Блока для арбитражера, которые можно создать на основе окна блока Мультиарбитраж одним из способов, описанных выше, берут свои настройки из текущих опций Мультиарбитража.

Статистика

В процессе работы блока Мультиарбитраж с момента запуска программы/открытия окна с Мультиарбитражом собирается следующая статистика: считается число выходов арбитражей в зону сигнала (т.е. в область превышения заданного порога), средняя величина (в секундах) продолжительности сигналов, минимальное и максимальное время сигнала.

Статистику можно посмотреть для каждой конкретной пары инструментов (контекстное меню по щелчку правой кнопкой мыши над соответствующим графиком), для всех пар на один базис (по меню Мультиарбитраж|Статистика) для активного окна мультиарбитража, а также для всех арбитражей из всех открытых окон блока Мультиарбитраж (по меню Мультиарбитраж|Глобальная статистика).

На формах с таблицами со статистикой есть кнопка Очистить, после нажатия которой статистика, показываемая в таблице, начинает накапливаться заново.


Блок для хеджера

Блок для хеджирования купленных акций от падения цены акции

Описание наполнения

Состоит из анализа комбинаций ("покупка акций"+опционы) и выбора наименее рискованных из них.

Рассматривается два варианта:

  1. покупка пут-опционов: стоимость портфеля равна (стоимость 1 контрактного лота акций) + (число опционов) * (стоимость опциона), затраты на хеджирование равны (число опционов) * (стоимость опциона)
  2. продажа колл-опционов: стоимость портфеля равна (стоимость 1 контрактного лота акций) - (число опционов) * (стоимость опциона)

Под 1 контрактным лотом акций понимается число акций, составляющих специфицированный биржей фьючерсный контракт. Например, для РАО ЕЭС один контрактный лот равен 1000.

Количество опционов h считается в относительных единицах, от 0 до 1. Это означает следующее: при h=0 опционов в портфеле нет. При h=1 рассматривается число опционов равным числу контрактных лотов акций (для РАО ЕС на 1 контрактный лот (т.е. 1000 акций) в портфеле 1 опцион). Остальные значения h промежуточные между описанными выше случаями. Величину h можно назвать коэффициентом хеджирования.

Считаются следующие характеристики при фиксированной доле опционов, равной h=0, 0.25, 0.5, 0.75, 1.

  1. средняя доходность (в пересчете на годовую) на заданную дату;
  2. максимальные потери VAR на заданную дату, которые можно понести с заданной вероятностью gamma (т.е. в заданный момент времени с вероятностью gamma потерь больше, чем VAR, не будет). Значение VAR выдается в виде доли от исходной стоимости портфеля. Например, пусть gamma=0.95. Тогда значение VAR=0.2 означает, что с вероятностью 0.05=1-gamma возможны потери в размере, большем, чем 20% от вложенных денег (исходной стоимости портфеля). По–другому можно сказать, что с вероятностью 0.95 потерь, больших чем 20%, не будет.
  3. затраты на хеджирование: если мы предполагаем, что акции у нас уже есть, то для их хеджирования покупкой пут-опционов, необходимы затраты в размере (число опционов) * (стоимость опциона);
  4. объем, который соответствует заданной глубине стакана, используемой при определении стоимости комбинации;

Далее, задается минимальная доходность, которая устраивает хеджера, рассматриваются все варианты с доходностью, большей чем минимальная, и выдаются результаты в порядке возрастания риска (VAR).

Для вычислений требуется задать дату t, на которую нас интересуют характеристики портфеля, минимальную устраивающую хеджера доходность, а также входные параметры в одной из двух форм:

  1. оценка скорости роста цен акций (в пересчете на год) с данного момента до момента t, годовая волатильность (предполагается неизменной), ожидаемая безрисковая ставка на момент t;
  2. предсказание значения цены 1 контрактного лота акций (наиболее вероятное значение + ошибка предсказания в виде стандартного отклонения), ожидаемая безрисковая ставка на момент t, ожидаемое значение волатильности на момент t.

Пример работы с блоком "Хеджер"

  1. Запустить программу.
  2. Для первого ознакомления с программой можно начать в режиме off-line с рассмотрения результатов на основе сохраненных данных: Связь|Загрузить из Excel – загрузка данных, которые были сохранены в прошлый раз с помощью Связь|Сохранить в Excel
  3. Для работы в on-line используйте Связь|Соединиться (предполагается, что установки для соединения уже были настроены ранее с помощью Связь|Параметры)
  4. Выбрать Блоки|Параметры. Там можно установить параметры, смысл которых определен в описании общей структуры программы.
  5. Выбрать Блоки|Хеджер.
  6. В появившемся окне выбрать базисный актив (например, РАО ЕЭС), тип хеджирования (например, продажа КОЛЛ) и дату, на которую хотите провести расчеты. Если вы хотите использовать стаканы котировок для учета нескольких лучших котировок и их объемов, то нужно поставить галочку Использовать стаканы, иначе будут использоваться только лучшие котировки. (Внимание: загрузка стаканов для базисного актива, для которого эта загрузка потребовалась в первый раз после запуска программы, может занять некоторое время.) Появится окно из блока "Хеджер" с выбранными установками.
  7. Можно проделать предыдущий пункт еще раз, выбрав те же установки за исключением типа хеджирования – установите покупка ПУТ.
  8. С помощью меню Окна|Рядами можно сделать так, чтобы оба открытых окна были видны.
  9. Выбрать Хеджер|Настройки. Установить там необходимые параметры. Установите способ задания параметров (для хеджера более естественен первый способ, так как второй способ – это задание прогноза значения цены). Установить значения gamma=0.95, ожид. волатильность (например, 0.5, т.е. 50%), ожидаемый рост (например, 0.1 – 10% годовых). Обратите внимание, что параметры, помеченные знаком '*', отличаются для разных базисных активов. Поэтому для их изменения выбирать меню Хеджер|Настройки нужно при активном окне, относящемся к данному базисному активу.
  10. Так как вычисления могут занять ощутимое время (несколько секунд, если выбрана дата, отличная от момента истечения; на момент истечения вычисления проходят практически незаметно), то рекомендуется поставить соответствующее значение для времени, через которое будет проходить обновление данных в режиме on-line. Например, можно установить 20 секунд. Другой вариант: установить очень большое значение, а потом при необходимости обновлять результаты через меню Хеджер|Обновить (обновление активного окна) или Хеджер|Обновить все (обновление всех окон блока Хеджер).
  11. Все, можно разглядывать результаты.


Блок для спекулянта

Блок для спекуляций с опционами

Описание наполнения

Состоит из анализа комбинации из одного или двух опционов и выбора наиболее доходных из них.

Рассматриваем след комбинации (в скобках указано поведение цен, при котором может проявиться выигрыш от данной комбинации):

  1. продажа колл (цены падают)
  2. покупка колл (цены растут)
  3. продажа пут (цены растут)
  4. покупка пут (цены падают)
  5. покупка колл, продажа колл (если цены падают, то страйк продажи должен быть меньше страйка покупки, иначе – наоборот)
  6. покупка колл, покупка пут (большая волатильность)
  7. продажа колл, продажа пут (маленькая волатильность).
  8. покупка пут, продажа пут (если цены падают, то страйк продажи должен быть меньше страйка покупки).

Затраты на портфель (комбинацию), по отношению к которым считается доходность и VAR, считаются следующим образом: для покупаемого опциона его стоимость берется с плюсом, для продаваемого – с минусом, затем складываются полученные значения, и берется абсолютное значение результата.

Считаются следующие характеристики:

  1. средняя доходность (в долях, в пересчете на годовую) на заданную дату (число 2.5 означает 250% годовых);
  2. максимальные потери VAR на заданную дату, которые можно понести с заданной вероятностью gamma (т.е. в заданный момент времени с вероятностью gamma потерь больше, чем VAR, не будет). Значение VAR выдается в виде доли от исходных затрат на порфель. Например, пусть gamma=0.95. Тогда значение VAR=0.2 означает, что с вероятностью 0.05=1-gamma возможны потери в размере, большем, чем 20% от вложенных денег. По-другому можно сказать, что с вероятностью 0.95 потерь больших, чем 20%, не будет.
  3. шанс (вероятность) выигрыша. С такой вероятностью выход из позиции будет с положительным доходом. Эта характеристика дополняет предыдущие две, так как возможна ситуация с большим средним доходом, с небольшим VAR, но большой средний доход получается за счет большого по величине выигрыша с маленькой вероятностью (т.е. с большой вероятностью трейдер уйдет в минус по этой позиции).

Если при образовании блока было выбрано использование стакана, то считаются также следующие характеристики:

  1. объем комбинации, который позволяет получить заданная глубина стакана;
  2. максимальная стоимость комбинации (вернее, затраты на комбинацию) с учетом объема, который соответствует комбинации при заданной глубине стакана (равна стоимости, умноженной на объем);
  3. максимальный средний доход, который позволяет получить объем, соответствующий комбинации при заданной глубине стакана;
Характеристики, связанные с объемом, дают возможность увидеть, какой реальный доход позволяют получить комбинации. Если доходность равна 10 (т.е. 1000%), стоимость комбинации равна 1 рублю (например, комбинация состоит из продажи и покупки опционов по схожим ценам), а реализуемый объем равен двум, то максимально из такой комбинации, супервыгодной по доходности, можно получить доход, равный всего лишь 20 рублям.

Далее, задается минимальная доходность, которая устраивает спекулянта, рассматриваются все варианты с доходностью большей, чем минимальная, и выдаются результаты в порядке убывания доходности.

Щелчками курсора мыши по заголовку столбца можно сортировать комбинации в порядке возрастания или убывания по любому столбцу.

Для вычислений требуется задать дату t, на которую нас интересуют характеристики портфеля, минимальную устраивающую хеджера доходность, а также входные параметры в одной из двух форм:

  1. оценка скорости роста цен акций (в пересчете на год) с данного момента до момента t, годовая волатильность (предполагается неизменной), ожидаемая безрисковая ставка на момент t
  2. предсказание значения цены 1 контрактного лота акций (наиболее вероятное значение + ошибка предсказания в виде стандартного отклонения), ожидаемая безрисковая ставка на момент t, ожидаемое значение волатильности на момент t.

Графические возможности блока "Спекулянт"

По выделенной строке таблицы можно получать с помощью контекстного меню График.дополнительную графическую информацию. На графике линией изображена зависимость дохода комбинации от цены 1 контрактного лота акций в заданный момент времени t. Одновременно на график помещена гистограмма, характеризующая распределение цены 1 контрактного лота акций в заданной модели поведения цен. Высота столбца гистограммы пропорциональна вероятности того, что цена 1 контрактного лота акций в момент t будет в соответствующем промежутке. Гистограмма изображена в масштабе, удобном для восприятия.

Пример работы с блоком "Спекулянт"

  1. Запустите программу.
  2. Для первого ознакомления с программой можно начать в режиме off-line с рассмотрения результатов на основе сохраненных данных: Связь|Загрузить из Excel – загрузка данных, которые были сохранены в прошлый раз с помощью Связь|Сохранить в Excel
  3. Для работы в on-line используйте Связь|Соединиться (предполагается, что установки для соединения уже были настроены ранее с помощью Связь|Параметры)
  4. Выбрать Блоки|Параметры. Там можно установить параметры, смысл которых определен в описании общей структуры программы.
  5. Выбрать Блоки|Спекулянт.
  6. В появившемся окне выбрать базисный актив (например, РАО ЕЭС), варианты комбинаций (например, все) и дату, на которую хотите провести расчеты. Также можно разрешить смешивание ближних и дальних опционов (при ознакомлении с программой лучше их не смешивать). Этот блок самый трудоемкий и уменьшение числа комбинаций убыстряет вычисления. Если вы хотите использовать стаканы котировок для учета нескольких лучших котировок и их объемов, то нужно поставить галочку Использовать стаканы, иначе будут использоваться только лучшие котировки. (Внимание: загрузка стаканов для базисного актива, для которого эта загрузка потребовалась в первый раз после запуска программы, может занять некоторое время.) Появится окно блока "Спекулянт" с выбранными установками.
  7. Можно проделать предыдущий пункт еще раз, выбрав те же установки за исключением даты или рассматриваемого базисного актива.
  8. С помощью меню Окна|Рядами можно сделать так, чтобы оба открытых окна были видны.
  9. Выбрать Спекулянт|Настройки. Установить там необходимые параметры. Установите способ задания параметров (для спекулянта, если он не строит прогноза значения цены, более естественен первый способ; если же существует прогноз цены на выбранную дату, то выбирайте второй способ). Начните со способа 1. Установите значения gamma=0.95, ожид. волатильность (например, 0.5, т.е. 50%), ожидаемый рост (например, 0.1 – 10% годовых). Обратите внимание, что параметры, помеченные знаком '*', отличаются для разных базисных активов. Поэтому для их изменения выбирать меню Спекулянт|Настройки нужно при активном окне, относящемся к данному базисному активу.
  10. Так как вычисления могут занять ощутимое время (десятки секунд, если выбрана дата, отличная от момента истечения, и установлен тип вычислений Точные в Блоки|Параметры; на момент истечения вычисления проходят быстрее), то рекомендуется поставить соответствующее значение для времени, через которое будет проходить обновление данных в режиме on-line. Например, можно установить 60 секунд. Другой вариант: установить очень большое значение, а потом при необходимости обновлять результаты через меню Спекулянт|Обновить (обновление активного окна) или Спекулянт|Обновить все (обновление всех окон блока Спекулянт).
  11. Все, можно разглядывать результаты.

Замечание

При выборе второго способа задания цены (когда у нас есть прогноз и значение цены в будущий момент времени t считаем известным) могут возникнуть вопросы, почему так много комбинаций с одинаковой большой доходностью. Причина в следующем. При точном (или почти точном) прогнозе цены в большом числе комбинаций те деньги, которые будут получены, например, премия при продаже опциона, останутся у спекулянта. Это означает, что доход (премия) равен стоимости портфеля (которая также считается равной премии за опцион). Получаем 100% дохода за время до заданной даты. Если, например, до заданной даты 3 месяца, то в перечете в годовую доходность получим число 4, которое соответствует 400% годовых.

Замечание

Средняя доходность может быть очень большой в двух случаях.
  1. Когда до даты, на которую нас интересует стоимость комбинации, остается небольшое число дней, то даже небольшая средняя доходность при пересчет на год может превратиться в большое число.
  2. Когда стоимость комбинации мала (это касается комбинаций, состоящих из покупки и продажи опционов с близкими ценами), то даже не очень большой средний доход может превратиться в большую доходность из-за деления на маленькое число.


Блок Минипортфель

Блок для текущего анализа минипортфеля на один базисный актив

Описание наполнения

Блок позволяет анализировать и прогнозировать на заданную дату характеристики так называемого минипортфеля, состоящего из набора позиций (акции, фьючерсы, опционы) на один базисный актив. Гипотетическая стоимость создания/реализации позиций вычисляется по on-line котировкам на покупку и продажу (режим "авто"). Позиции можно фиксировать (режим "фикс."); тогда при их задании нужно указать стоимость приобретения.

Позиции можно задавать, редактировать, удалять. Минипортфель можно сохранять в файл специального формата и соответственно загружать из файла. При открытии окна с Минипортфелем пользователь имеет возможность задать имя портфеля. Это имя непосредственно поменять нельзя. Однако имя минипортфеля автоматически меняется, если созданный минипортфель сохранить в файл или, наоборот, загрузить минипортфель из файла. В этих случаях имя минипортфеля будет совпадать с именем файла.

При задании срочной позиции необходимо задать код соответствующего инструмента. Для того, чтобы в раскрывающемся списке Код: были предложены варианты кодов инструмента, нужно, чтобы они были загружены в программу. Это происходит в двух случаях: 1) если программа находится в режиме on-line; 2) если загружен файл с историческими данными (тогда будут доступны только коды инструментов, в нем сохраненные).

В качестве текущей даты рассматривается либо сегодняшняя дата при работе в режиме on-line, либо дата загруженного файла с историческими данными в режиме off-line.

Вычисляются следующие характеристики позиций минипортфеля на текущую дату (соответствующие основные характеристики всего минипортфеля также приводятся и являются просто суммой характеристик позиций):

  1. Код инструмента, тип позиции (длинная, короткая) и количество.
  2. Стоимость создания позиции. Гипотетическая стоимость основана на соответствующей котировке, средней по заданной глубине стакана или лучшей, в зависимости от того, была установлена галочка Использовать стаканы при образовании блока или нет. Если позиция длинная, то гипотетическая стоимость ее создания является положительной и основывается на котировках продажи, а если позиция короткая, то стоимость ее создания является отрицательной (и основывается на котировках покупки). В режиме фиксированной позиции этот столбец содержит введенную пользователем при создании/редактировании позиции цену.
  3. Стоимость реализации позиции, основанная на соответствующей котировке. Если позиция длинная, то стоимость ее реализации является положительной и основывается на котировках покупки, а если позиция короткая, то стоимость ее реализации является отрицательной (и основывается на котировках продажи).
  4. Теоретическая стоимость позиции, вычисленная на основе цены акции по теоретическим формулам. В качестве цены акции на текущий момент берется цена последней сделки по акциям. Теоретическая стоимость фьючерса определяется по цене акции (вернее, по цене 1 контрактного лота акций) на основе заданной безрисковой ставки (меню Блоки|Параметры). Теоретическая стоимость опциона определяется по формуле Блека-Шоулса также на основе цены 1 контрактного лота акций. При этом используется та же безрисковая ставка, что и для фьючерса, а также Текущ. волатильность, устанавливаемая в Минипортфель|Настройки. Заметим, что этот параметр для каждого базисного актива свой, однако это та же волатильность, которая устанавливается в настройках блока "Калькулятор опционов" (изменение текущей волатильности в настройках блока "Минипортфель" приводит к изменению волатильности в настройках блока "Калькулятор опционов" и наоборот).
  5. греки (производные теоретической стоимости позиции по разным параметрам), появляются при установке галочки Греки в опциях Минипортфель|Настройки, страница Вид.

При вычислении характеристик всего портфеля, если нет нужной котировки на хотя бы одну из позиций портфеля, то суммарная характеристика не вычисляется.

В нижней части окна блока Минипортфель находятся прогнозируемые на основе заданной модели поведения цен характеристики минипортфеля на заданные даты. Некоторые характеристики (такие как доходность и ValueAtRisk) выдаются в относительных к исходным затратам на портфель единицах. В качестве таких исходных затрат берется абсолютная величина (модуль) текущей (на текущую дату) стоимости создания портфеля.

Считаются следующие характеристики на заданную дату:

  1. средний доход в рублях
  2. средняя доходность (в долях, в пересчете на годовую) на заданную дату (число 2.5 означает 250% годовых); если есть фиксированные позиции, то доходность не вычисляется, так как дата создания портфеля перестает быть привязанной к текущей дате и становится неопределенной;
  3. максимальные потери VAR на заданную дату, которые можно понести с заданной вероятностью gamma (т.е. в заданный момент времени с вероятностью gamma потерь больше, чем VAR, не будет). Значение VAR выдается в виде доли от исходных затрат на портфель. Например, пусть gamma=0.95. Тогда значение VAR=0.2 означает, что с вероятностью 0.05=1-gamma возможны потери в размере, большем, чем 20% от исходно затраченных денег. По-другому можно сказать, что с вероятностью 0.95 потерь больших, чем 20%, не будет.
  4. шанс (вероятность) выигрыша. С такой вероятностью выход из позиции будет с положительным доходом. Эта характеристика дополняет предыдущие две, так как возможна ситуация с большим средним доходом, с небольшим VAR, но большой средний доход получается за счет большого по величине выигрыша с маленькой вероятностью (т.е. с большой вероятностью трейдер уйдет в минус по этой позиции).
  5. средняя стоимость портфеля. Она равняется сумме текущей стоимости портфеля и дохода.

Для вычисления всех характеристик кроме прогнозируемой стоимости портфеля используется стоимость создания портфеля. Поэтому при ее отсутствии (вызванном отсутствием котировок для хотя бы одной из нефиксированных позиций) заполненным является только поле "Стоимость".

Для вычислений прогнозируемых характеристик кроме задания даты t требуется задать входные параметры (меню Минипортфель|Настройки) в одной из двух форм:

  1. оценка скорости роста цен акций (в пересчете на год) с данного момента до момента t, годовая волатильность (предполагается неизменной), ожидаемая безрисковая ставка на момент t
  2. предсказание значения цены 1 контрактного лота акций (наиболее вероятное значение + ошибка предсказания в виде стандартного отклонения), ожидаемая безрисковая ставка на момент t, ожидаемое значение волатильности на момент t.

Заметим, что ожидаемые на дату t параметры являются едиными для блоков "Минипортфель", "Спекулянт" и "Хеджер".

Свойства окна с результатами

В блоке "Минипортфель" результаты расположены в виде окна с двумя таблицами и с вертикальным скроллингом при высоте окна меньше, чем максимальная. Для более удобного просмотра рекомендуется расположение на рабочем столе не более двух окон типа Минипортфель и выбор режима расположения Окна|Колонками .

При высоте окна меньше максимальной переход между верхней и нижней таблицам происходит с помощью скроллинга и/или щелчка мышью по области нужной таблицы.

Графические возможности блока "Минипортфель"

По выделенной строке таблицы в нижней части окна блока Минипортфель (Прогноз на дату) с помощью кнопки График (если высота окна не максимальная, то она может быть не видна) или соответствующего пункта контекстного меню можно получать дополнительную графическую информацию. На графике линией изображена зависимость дохода минипортфеля от цены 1 контрактного лота акций в заданный момент времени t. Одновременно на график помещена гистограмма, характеризующая распределение цены 1 контрактного лота акций в заданной модели поведения цен. Высота столбца гистограммы пропорциональна вероятности того, что цена 1 контрактного лота акций в момент t будет в соответствующем промежутке. Гистограмма изображена в масштабе, удобном для восприятия.

Замечание

Средняя доходность может быть очень большой в двух случаях.
  1. Когда до даты, на которую нас интересует стоимость минипортфеля, остается небольшое число дней, то даже небольшая средняя доходность при пересчет на год может превратиться в большое число.
  2. Когда исходные затраты на минипортфель малы (это касается случая, когда короткие позиции уравновешивают длинные), то даже не очень большой средний доход может превратиться в большую доходность из-за деления на маленькое число.


Блок Комбинации

Блок для выбора комбинаций/спредов из опционов согласно заданному сценарию развития рынка

Описание наполнения

Блок позволяет задать один из четырех сценариев поведения цен базисного актива: рост, падение, резкое изменение, боковик - и получить на выбор список комбинаций/спредов из опционов, которые могут принести прибыль при заданном сценарии. Чтобы получить только варианты, в которых риски ограничены, нужно поставить галочку Ограниченные убытки. Рассматриваются только комбинации/спреды из опционов с одинаковым сроком истечения на один и тот же базисный актив. При открытии блока Комбинации пользователь имеет возможность выбрать базисный актив и задать срок истечения опционов, из которых он хочет создать комбинированную позицию. В качестве набора страйков рассматривается тот же набор, что и в опционном калькуляторе. Т.е. это те страйки, которые есть в стаканах котировок, загруженных либо on-line, либо из файла hist.xls при работе в off-line. Поэтому если опционы с выбранным базисным активом и сроком истечения не торгуются, то такой выбор смысла не имеет.

Окно блока Комбинации состоит из двух страниц. На первой странице слева расположен список названий комбинированных опционных позиций, а справа изображается график зависимости дохода на дату истечения опционов от цены базисного актива для выделенной комбинации. При этом набор страйков выбирается стандартным способом: страйки выбираются ближайшими к текущей цене базисного актива и симметричными. Например, при цене фьючерса 8050 и страйках 7000, 7500, 8000, 8250, 8500, 9000 для комбинации из трех опционов с разными страйками будут выбраны страйки 7500, 8000, 8500.

Для того чтобы посчитать доход, нужно знать, по каким ценам покупались/продавались опционы. Так как график на первой странице служит лишь для создания представления о выбираемой комбинации, там используется предположение, что опционы продавались/покупались по справедливым ценам. Напомним, что справедливые цены основаны на заданной безрисковой ставке (меню Блоки|Параметры) и на заданной волатильности для рассматриваемого фьючерса. Волатильность задается в настройках блока: при активном окне блока Комбинации нужно выбрать меню Комбинации|Настройки), страница Вычисления. Для задания волатильности можно ориентироваться на так называемую подразумеваемую волатильность, значения которой вычисляются в блоке Калькулятор опционов. Можно брать значения, лежащие между поразумеваемыми в котировках на покупку и продажу волатильностями, а также ориентироваться на волатильности, подразумеваемые в совершенных сделках (соответствующие столбцы появляются, если перейти в расширенный режим просмотра с помощью меню Блоки|Параметры).

По кнопке Вперед пользователь попадает на вторую страницу окна. Вторая страница позволяет

  1. Увидеть, из чего состоит выбранная комбинированная позиция. Например, +2PUT означает, что в позицию входят два купленных (long) опциона PUT со страйком, заданным рядом в окошке.
  2. Менять страйки опционов. Это можно делать как выбирая нужный страйк из списка, так и смещая и сдвигая/раздвигая все страйки одновременно с помощью специальных кнопок.
  3. Узнать, какова стоимость приобретения всей комбинации целиком. Если стоимость положительная, то это означает, что за приобретение комбинации нужно заплатить (длинная позиция). Если стоимость отрицательная, то это означает, что при приобретении комбинации на счет добавится указанная сумма (короткая позиция).
  4. Сравнить справедливые цены опционов и суммарной позиции с рыночными, задаваемыми лучшими котировками на покупку и продажу.
  5. Установить дату расчета (по умолчанию устанавливается дата истечения опционов из комбинации). Установленная дата останется в силе и при выборе другой комбинированной позиции.
  6. Сравнить графики зависимости дохода от цены базисного актива при использовании справедливых и рыночных цен, на заданную дату. Напомним, что двойным щелчком по графику можно узнать значения в любой точке графика. В частности, определить точки безубыточности позиции двойным щелчком по точке пересечения графика дохода с нулем.

При вычислении рыночных характеристик всего портфеля, если нет нужной котировки на хотя бы одну из позиций портфеля, то суммарная характеристика не вычисляется. На графике, который представлен справа, всегда изображается зависимость дохода от цены базисного актива, в которой доход вычисляется на основе справедливых цен опционов. Если есть котировки на все опционы, участвующие в комбинированной позиции, то на график добавляется зависимость дохода, сосчитанного по рыночным ценам.

Если, находясь на второй странице, нажать кнопку Назад и после этого, не меняя комбинации, кнопку Вперед, то страйки комбинации, установленные на второй странице, не изменятся. Если поменять на первой странице комбинацию, а потом вернуться к предыдущей комбинации, то страйки установятся в стандартные.

Заметим, что прибыльность комбинации при заданном сценарии изменения цен будет не при любом сочетании страйков. Это касается позиций, состоящих из более чем двух опционов. Как правило, при стандартном выборе страйков прибыльность достигается.

Опции блока, в которых можно задать значение волатильности (для каждого базисного актива задается своя волатильность), можно вызвать по меню Комбинации|Настройки при активном окне блока Комбинации. Задаваемое значение волатильности одно и то же для блоков Калькулятор опционов и Комбинации. Это означает, что если в блоке Калькулятор опционов поменять значение волатильности для некоторого базисного актива, то оно также изменится и в блоке Комбинации. И наоборот.


Калькулятор опционов

Описание наполнения

Блок содержит набор стандартных характеристик опционов:

  1. котировки на покупку и продажу (лучшие или средневзвешенные по объемам, вычиленные по заданной глубине стакана котировок);
  2. объем, по которому считалась средневзвешенная котировка (если был выбран способ расчета на основе стакана);
  3. подразумеваемые волатильности (покупаемая и продаваемая), обозначаемые IV - implied volatility;
  4. справедливая цена опциона
  5. греки (производные справедливой цены опциона по разным параметрам), появляются при установке галочки Греки в опциях Опц.калькулятор|Настройки, страница Вид.

Таблица также содержит столбцы, относящиеся к последним сделкам: их цены и соответствующие подразумеваемые волатильности (IV). Также приведены времена сделок. Так как время сделки определяется по изменению ее цены/объема, то если сделка была совершена до загрузки программы, то время не указывается.

При вычислении справедливой цены опциона (а также греков) используются следующие входные данные (котировки не используются):

  • безрисковая ставка на текущий день (общая для всех блоков и всех базисных активов), устанавливаемая в общих опциях Блоки|Параметры;
  • волатильность, устанавливаемая отдельно для данного блока через Калькулятор опционов|Настройки (можно установить разные значения для разных базисных активов при активном окне с тем или иным базисным активом);
  • тип опциона (европейский с вычислениями по модели Блека/Блека-Шоулса или американский с вычислениями по биномиальной модели); тип устанавливается при открытии блока "Калькулятор опционов".

При вычислении подразумеваемой волатильности используются

  • цена сделки или соответствующая котировка на покупку/продажу
  • безрисковая ставка на текущий день (общая для всех блоков и всех базисных активов), устанавливаемая в общих опциях Блоки|Параметры
  • тип опциона, устанавливаемый при открытии блока "Калькулятор опционов".

Подразумеваемая волатильность, во-первых, является единой мерой того, насколько соответствующая котировка слишком высока/низка для разных страйков и типов (колл или пут) опционов. Во-вторых, подразумеваемую волатильность (например, среднюю между продаваемой и покупаемой волатильностями или среднюю волатильность, заложенную в цены сделок) можно использовать в других блоках как оценку параметра Волатильность.

Заметим, что средняя волатильность вычисляется не как простое арифметическое среднее, а как взвешенное среднее, где опционам "около денег" придается больший вес, а чем дальше страйк опциона от текущей цены фьючерса, тем меньше его вклад в сумму. В качестве весов используются нормированные значения гаммы (второй производной цены опциона по цене базисного актива).

Сигналы

В блоке есть возможность устанавливать сигналы, если котировка на продажу низкая, а котировка на покупку – высокая (Калькулятор опционов|Настройки, страница Сигналы). Стоимость опциона измеряется в терминах подразумеваемой волатильности (чем меньше подразумеваемая волатильность, тем меньше стоимость опциона). Поэтому если продаваемая подразумеваемая волатильность меньше заданного числа, то подается сигнал на покупку (подсветка цветом и, при желании, звуковой сигнал). При покупаемой волатильности, большей заданного значения, подается сигнал на продажу.

Пример работы с блоком " Калькулятор опционов"

  1. Запустите программу.
  2. Для первого ознакомления с программой можно начать в режиме off-line с рассмотрения результатов на основе сохраненных данных: Связь|Загрузить из Excel – загрузка данных, которые были сохранены в прошлый раз с помощью Связь|Сохранить в Excel
  3. Для работы в on-line используйте Связь|Соединиться (предполагается, что установки для соединения уже были настроены ранее с помощью Связь|Параметры)
  4. Выбрать Блоки|Параметры. Там можно установить параметры, смысл которых определен в описании общей структуры программы.
  5. Выбрать Блоки|Калькулятор опционов
  6. В появившемся окне выбрать базисный актив (например, РАО ЕЭС) и тип опционов, ближний или дальний. Если вы хотите использовать стаканы котировок для учета нескольких лучших котировок и их объемов, то нужно поставить галочку Использовать стаканы, иначе будут использоваться только лучшие котировки. (Внимание: загрузка стаканов для базисного актива, для которого эта загрузка потребовалась в первый раз после запуска программы, может занять некоторое время.) Выберите также тип опционов, европейский или американский (рекомендуется выбрать европейский тип, так как для колл-опционов европейский тип не отличается от американского, а для пут-опционов разница небольшая; при этом вычисления по модели Блека-Шоулса точные и быстрые).
  7. Выбрать Калькулятор опционов|Настройки. Установить там необходимые параметры. Основной параметр - это волатильность, используемая при вычислении справедливой стоимости опционов. Также можно поменять установки сигналов.
  8. Все, можно разглядывать результаты.


Автопрогноз

Описание наполнения

Этот блок стоит особняком, так как, в отличие от всех других блоков, никак не связан с котировками. Поэтому он полноценно работает и в режиме off-line, но требует существования исторических данных. Он служит для анализа/прогноза исторических данных, которые или могут находиться в отдельном Excel файле, или браться из директории с данными Метастока.

Возможности блока:

  1. по ценовым временным рядам получать ряд доходностей и ряд волатильностей (последний может служить для оценки исторической волатильности, которую можно устанавливать в качестве параметра других блоков)
  2. нахождение константного или линейного тренда
  3. выделение тренда и/или колебаний с помощью метода "Гусеница"-SSA. Метод позволяет раскладывать ряд в сумму тренда, колебаний и шума, сглаживать ряды и, вообще говоря, подразумевает интерактивный анализ. В блоке Автопрогноз реализованы автоматические методы выделения тренда/колебаний.
  4. прогноз выделенного тренда/колебаний

Работа с блоком

Работа с блоком разделена на 5 шагов.

  • Шаг 1. Выбор ряда, который будет анализироваться в дальнейшем.
  • Шаг 2. Выделение отрезка выбранного на шаге 1 ряда для последующего анализа.
  • Шаг 3. Выделение из ряда константного или линейного тренда.
  • Шаг 4. Выделение из ряда тренда/колебаний с помощью метода "Гусеница" (в автоматическом режиме).
  • Шаг 5. Прогноз выделенных на этапах 3 и 4 компонент.

Последовательное переключение между шагами можно производить с помощью кнопок Вперед и Назад. Кроме первого шага, на котором надо обязательно задать временной (ценовой) ряд, можно перескакивать через шаги (а также возвращаться назад) с помощью кнопки Шаг №. При перескакивании через шаги вперед все действия, соответствующие этим шагам, производятся с теми параметрами, которые были установлены до того (или параметрами по умолчанию, если значения параметров не менялись).

На каждом шаге есть кнопка График, по которой можно посмотреть график, являющийся результатом этого шага с текущими параметрами.


Автопрогноз, Шаг 1

Шаг 1. Выбор ряда, который будет анализироваться в дальнейшем

На шаге 1 необходимо выбрать временной ряд. Он может быть:

  1. сгенерирован в стандартной модели геометрического броуновского движения (параметры: однодневная волатильность и однодневная доходность).
  2. загружен из файла в формате Excel (.xls); есть возможность задать в интерактивном режиме, в каком столбце расположены данные и с какой строки ни начинаются.
  3. импортирован из директории с данными в формате программы Метасток.

Так как импорт данных из Метастока является наиболее актуальным способом задания ценового ряда, то остановимся на нем поподробнее.

Сначала по кнопке Задать нужно выбрать папку, в которой расположены данные. После этого пользователю будет предложен список тиккеров, находящихся в указанной папке. Затем необходимо выбрать один из тиккеров и установить переключатель внизу на тип данных (High, Low, Open, Close, Volume). Если поставить галочку на "Преобразовать внутридневные данные в дневные", то на основе импортированных данных будет образован ряд из средневзвешенных дневных цен (для Volume эта операция смысла не имеет). При импорте данных в формате Метасток также автоматически импортируются даты/времена, которым соответствуют данные. На графиках эта информация используется в виде подписей к оси X.

Если был загружен произвольный, не ценовой, ряд, то его преобразования смысла не имеют; поэтому рекомендуется не менять вариант по умолчанию "Не преобразовывать".

Если же был загружен ценовой ряд, то имеют смысл следующие преобразования:

  • в ряд доходностей, который строится как логарифм отношения последовательных цен.
  • в ряд волатильностей (в пересчете в годовые проценты); каждое значение волатильности вычисляется на основе отрезка ряда цен длиной, равной параметру "Ширина окна". Вариант "В ряд волат. (неперекр.)" соответствует вычислению волатильностей по последовательным непересекающимся отрезкам ряда цен. Вариант "В ряд волат. (перекр.)" соответствует вычислению волатильностей на основе скользящих отрезков ряд цен (например, при ширине окна, равной 20, это отрезок с 1-й по 20-ю точку, со 2-й по 21-ю и т.д.).


Автопрогноз, Шаг 2

Шаг 2. Выделение отрезка выбранного на шаге 1 ряда для последующего анализа

Этот шаг предоставляет возможность анализировать не весь ряд целиком, а только его часть.

По умолчанию стоит галочка на Использовать весь ряд, но если ее убрать, то можно установить границы отрезка ряда двумя способами. В обоих способах нужно задать длину отрезка плюс номер последней точки отрезка (он по умолчанию устанавливается равным последней точке всего ряда) в первом случае или номер первой точки отрезка во втором варианте.

Выбор длины отрезка ряда, на основе которого предполагается проводить дальнейший прогноз, должен подчиняться следующим принципам. С одной стороны, структура ряда (тренд, циклы) должна быть более-менее стабильной, без внешних воздействий, поэтому длина отрезка не должна быть слишком большой. С другой стороны, чем больше отрезок, тем лучше.


Автопрогноз, Шаг 3

Шаг 3. Выделение из ряда константного или линейного тренда

Шаг 3 предоставляет возможность по желанию пользователя выделить из ряда параметрический тренд в двух формах: константный или линейный (линейная регрессия).

Если выбран один из способов выделения простого тренда, то этот тренд будет вычтен из ряда и на следующем шаге будет проводиться анализ остатка.


Автопрогноз, Шаг 4

Шаг 4. Выделение из ряда тренда/колебаний с помощью метода "Гусеница"

На данном шаге реализован автоматический способ идентификации компонент разложения временного ряда, построенного с помощью метода "Гусеница". Предоставляется возможность идентифицировать компоненты, относящиеся к тренду, компоненты, относящиеся к гармоническим составляющим ряда, а также и те и другие вместе.

Есть также возможность использовать заданное число первых компонент разложения, не используя автоматическую идентификацию. Так как компоненты упорядочены по убыванию их вклада, то выбор первых компонент соответствует задаче выделения сигнала из шума.

Если на предыдущем этапе выделялся простой тренд, то на этом этапе есть возможность вообще не применять метод "Гусеница", установив переключатель в положение "Ничего не выделять".

Остановимся коротко на параметрах данного этапа, которые можно поменять по кнопке Дополнительно... . Для построения разложения с помощью метода "Гусеница" нужно выбрать его основной параметр, называемый "длина окна". Он может быть задан в двух формах, или как абсолютное значение (больше 1 и меньше длины ряда), или в долях от длины ряда. По умолчанию он устанавливается равным половине длины анализируемого ряда, что соответствует самому подробному разложению. Но можно выбрать его и меньше, но не слишком маленьким, чтобы в длину окна укладывалось несколько периодов циклов, которые пользователь хочет выделить. Если периоды циклов известны, то лучше, если длина окна делится на них (по крайней мере, на максимальный).

Так как скорость вычислений очень сильно зависит от длины окна, то при длине ряда больше одной-двух тысяч (эта граница определяется, конечно, характеристиками компьютера) имеет смысл уменьшить длину окна.

Параметр Макс. PC (т.е. максимальное число анализируемых главных компонент) влияет на скорость разложения и идентификации, а также он ограничивает число идентифицируемых компонент, поскольку компоненты с большими номерами, как правило, соответствуют шуму. По умолчанию он равен 50.

Теперь коснемся параметров идентификации, которая базируется на анализе собственных векторов, так как их поведение в некотором смысле повторяет поведение составляющей временного ряда, восстановленной по компоненте, включающей данный собственный вектор. Идентификация тренда основана на той идее, что к тренду относятся медленно меняющиеся компоненты. Следовательно, в разложении Фурье данной компоненты по частотам вклад низких частот должен быть достаточно большим. Параметр Период в "Настройках для тренда" обозначает границы частот, понимаемых как низкие (напомним, что частота равна единице, деленной на период). Значение C0, которое должно лежать между 0 и 1 и быть достаточно большим, означает вклад низких частот в Фурье-разложение компоненты (собственного вектора). Например, значение периода, равное 21, и значение порогового значения, равное 0.8, установленные по умолчанию, означают, что при рассмотрении дневных данных к тренду будут отнесены те собственные вектора, у которых компоненты Фурье-разложения с периодом, большим 21 (примерно месяц), будут давать вклад, больший 0.8 (80%).

Опишем настройки для идентификации гармоник. Параметр s0 надо устанавливать в 0 или в 1; этот параметр связан с дискретностью решетки частот в разложении Фурье, которое также является базовым для идентификации. На основе анализа собственных векторов ищутся их пары, которые, полагаясь на теорию, должны соответствовать гармонике. Качество соответствия можно охарактеризовать с помощью некоторой величины. Если качество соответствия больше значения параметра ro0 (оно должно быть между 0 и 1, ближе к 1), то предполагается, что эта пара собственных векторов порождает гармоническую составляющую ряда. При выделении гармоники можно оценить ее период. Параметры Мин. период и Макс. период дают границы для периода, который может быть у гармоники. По умолчанию Мин. период равен 0. Если установить его, например, равным 4, то все гармоники с меньшим периодом будут отнесены к шуму и не будут рассматриваться.

Настройки для выделения сигнала совсем просты и состоят в выборе количества первых компонент для восстановления сигнала.

Отметим, что выделение методами идентификации тренда или гармоники не является гарантией того, что это неслучайные компоненты.


Автопрогноз, Шаг 5

Шаг 5. Прогноз выделенных на этапах 3 и 4 компонент

Единственным параметром данного этапа является число точек прогноза. Сам прогноз строится с помощью сложения непосредственного продолжения константного или линейного тренда (если такой тренд выделялся на третьем этапе), и так называемого рекуррентного прогноза компонент, выделенных на четвертом этапе.


Блок корреляций

Блок для подсчета корреляций

Данный блок предназначен для подсчета корреляций между заданным ценовым рядом и набором других рядов. Также, как и блок Автопрогноза, этот блок никак не связан с котировками. Поэтому он полноценно работает и в режиме off-line, но требует существования исторических данных, которые загружаются из директории с данными Метастока.

Блок позволяет считать корреляции как между ценами, так и между рядами из доходностей, вычисляемых на основе выбранных ценовых рядов. При этом считаются и обычные корреляции, которые являются мерой линейной зависимости двух рядов, и ранговые корреляции, которые являются мерой монотонной зависимости двух рядов. Например, если один положительный ряд полностью определяется значениями другого ряда (например состоит из квадратов этих значений), то ранговая корреляция будет равна +1 или -1 (в зависимости от того, возрастающая зависимость или убывающая), а значения обычной корреляции могут быть достаточно малы и тем самым не показывать существующую жесткую зависимость. Другим достоинством ранговой корреляции является ее устойчивость к выделяющимся значениям в данных (резким скачкам, просто ошибочным значениям).

Большая (близкая к 1) корреляция между ценами разных базисных активов может означать, например, что для хеджирования одного из них можно использовать опционы для другого. Нулевая и отрицательная корреляция может говорить о том, что включив в портфель оба инструмента, можно снизить риск портфеля.

Корреляция между самими ценами показывает в большей степени зависимость между глобальным (трендовым) поведением цен. Если, например, цены двух акций в целом растут, но колеблются вокруг тренда в противофазе, то корреляция между ценами будет положительной, а корреляция между приращениями цен (и между доходностями) - отрицательной.

Если посчитать корреляцию между ценами одной и той же акции, Close и Open, то корреляция между ними естественно будет близка к 1. Однако корреляция между приращениями Open и Close может оказаться близкой к нулю (например, для часовых данных).

Работа с блоком состоит из 2-х шагов:

Шаг 1.

На шаге 1 необходимо выбрать ценовые ряды, которые будут импортированы из директории с данными в формате программы Метасток.

Сначала по кнопке Задать исходный ряд нужно выбрать папку, в которой расположены данные. После этого пользователю будет предложен список тиккеров, находящихся в указанной папке. Затем необходимо выбрать один из тиккеров и установить переключатель внизу на тип данных (High, Low, Open, Close, Volume). Если поставить галочку на "Преобразовать внутридневные данные в дневные", то на основе импортированных данных будет образован ряд из средневзвешенных дневных цен (для Volume эта операция смысла не имеет). При импорте данных в формате Метасток также автоматически импортируются даты/времена, которым соответствуют данные. На графиках эта информация используется в виде подписей к оси X.

Затем с помощью кнопки Добавить нужно создать список тиккеров рядов, с которыми будут считаться корреляции исходного ряда. Задание рядов полностью аналогично описанному выше, только добавляется возможность выбрать сразу несколько тиккеров, используя клавиши CTRL или SHIFT.

Заметим, что при подсчете корреляций между двумя рядами используются только пары значений, синхронизированные по времени. Значения одного ряда, к которым нет парных с тем же временем/датой в другом ряде, не участвуют в вычислениях. Поэтому, например, можно считать корреляции между часовыми и минутными данными.

На шаге 1 предоставляется возможность задать начальную и конечную даты для подсчета корреляций не по всему максимальному временному промежутку, а по заданному.

По кнопке График рисуются графики всех выбранных рядов. Так как цены для разных тиккеров могут быть в несравнимых масштабах, то графики рисуются в стандартизованном виде: среднее каждого ряда становится равным 0, а разброс (дисперсия) равным 1.

Шаг 2.

Результатом шага 2 являются корреляции, обычные и ранговые, между выбранными ценовыми рядами и посчитанными по ним рядами доходностей. В последней колонке указано число пар точек, синхронизированных по времени, по которым были сосчитаны корреляции.


Набор файлов

Набор файлов, входящих в программный комплекс

Обязательные:

  • TrinityNZ.exe – исполняемый файл
  • NiApi.dll – библиотека для связи через NetInvestor (нужна для работы в режиме on-line)

Файлы для хранения установок и данных (если их не было, то они образуются в процессе работы программы):

  • hist.xls – файл, в котором хранятся данные о котировках. Он заполняется текущими котировками при выборе меню Связь|Сохранить в Excel. При выборе меню Связь|Загрузить из Excel в режиме off-line котировки берутся из файла hist.xls. Поэтому, в принципе, можно поменять в файле значения руками и затем загрузить в программу.
  • AvArbitr.xls – файл, в котором хранится история по доходности, заложенной в синтетической облигации (покупка акции + продажа фьючерса).
  • connect_NI.ini – файл с настройками для связи с NetInvestor. После заполнения настроек связи в программе этот файл содержит секретную информацию (логин, пароль) и _не должен_ передаваться другим лицам при передаче файлов, относящихся к программе.
  • TrinityNZ.ini - файл с параметрами. В нем содержится информация о тикерах и рынках, а также параметры и настройки программы, которые были установлены при последнем запуске программы (сохранение параметров и настроек в оценочной версии отключено).

Файл с описанием программы и ее наполнения help.chm, вызываемый из программы по меню Помощь|Содержание или контекстно по клавише F1.

Для первого ознакомления с программой (за исключением блока Арбитраж) не обязательно выходить в режим on-line. Можно загрузить сохраненные в файле hist.xls котировки с помошью пункта меню Связь|Загрузить из Excel


Режимы работы программы

Режим on-line

Это основной режим программы. Перед первым входом в него с помощью кнопки или по меню Связь|Соединиться необходимо установить Параметры связи.

В блоках "Арбитраж" и "Калькулятор опционов" обновление происходит сразу после поступления новой котировки. В блоках "Спекулянт" и "Хеджер" есть возможность регулировать частоту обновлений, так как каждое обновление приводит к задержке, связанной с пересчетом всех таблиц.

Режим off-line

Данный режим служит для ознакомления с возможностями программы без доступа к on-line котировкам, а также для возможности сохранять состояния рынка в разные моменты времени и затем анализировать/сравнивать их.

Для работы в режиме off-line необходимо с помощью меню Связь|Загрузить из Excel загрузить в программу предварительно сохраненные (с помощью Связь|Сохранить в Excel) котировки. Файл с именем Hist.xls входит в дистрибутив программы и содержит котировки на момент создания дистрибутива. На его основе можно ознакомиться с программой, вообще не переходя в режим on-line. Загрузка котировок сама по себе не приводит к открытию окон. Поэтому для получения эффекта необходимо сначала открыть нужные окна с помощью пункта меню Блоки . Для обновления файла hist.xls рекомендуется переустановить программу, скачав дистрибутив программы с сайта Инновационной компании НЗ.

При сохранении файла с текущими котировками по умолчанию предлагается имя, состоящее из hist и текущей даты. При загрузке файла с котировками по умолчанию предлагается имя последнего сохраненного файла с котировками.

В файле с котировками содержится дата его создания, и после загрузки файла текущая дата устанавливается равной дате из файла (текущую дату можно увидеть в нижнем правом углу программы). После перехода в on-line дата меняется на сегодняшнюю.

Рекомендуется для загрузки файла с котировками на дату, отличающуюся от текущей, запускать новую копию программы.

Если пользователь меняет котировки в файле на другие, то необходимо следить за правильной датой.

Демо-режим

В демо-режиме котировки генерируются случайным образом на основе котировок из файла hist.xls. Для обновления файла hist.xls рекомендуется переустановить программу, скачав дистрибутив программы с сайта Инновационной компании НЗ. Вход в демо режим происходит по меню Связь|Запустить демо-режим, выход - по меню Связь|Завершить демо-режим.


Установка и регистрация программы

Установка

Для установки программы на компьютер необходимо запустить установочный файл программы и затем следовать инструкциям.

После установки программы программа будет работать в оценочном режиме.

Оценочная версия программы имеет следующие ограничения:

  • Все изменения параметров и настроек, которые делались в процессе работы программы, не действуют при следующем запуске программы (и сообщение об этом появляется при изменении параметров/настроек).
  • Оценочная версия работает только с базисным активом РАО ЕЭС и с глубиной стакана, не превосходящей 2.
  • Программа работает 30 дней с момента установки с ограничениями, указанными выше. После 30 дней работы перестает работать режим on-line получения котировок (можно только загружать старые котировки из файла hist.xls и работать в демо-режиме).

Регистрация

Порядок регистрации программы

  1. Необходимо произвести оплату стоимости программы (http://www.novationz.ru/)
  2. После получения подтверждения о произведенной оплате пользователю будет выслан личный регистрационный ключ
  3. Ключ необходимо скопировать из полученного регистрационного письма, а затем вставить (вызов контекстного меню по правой кнопке мыши и выбор Вставить или Paste) в окно регистрации программы. Окно регистрации вызывается либо по кнопке Регистрация..., либо через меню Помощь|Регистрация...
  4. Регистрационное письмо будет также содержать данные для доступа к котировкам через NetInvestor, необходимые для установления параметров связи (меню Связь|Параметры...)

Новую версию программы можно устанавливать поверх старой. Если перед установкой была сделана деинсталяции программы, то регистрационный ключ необходимо ввести заново.

Преимущества регистрации

  • Полная функциональность программы
  • Неограниченный срок использования
  • Получение регистрационных данных для доступа к котировкам через NetInvestor
  • Скидки при покупке последующих версий программы
  • Техническая поддержка


Греки

Смысл греческих символов

Греческими символами (отсюда короткое название – "греки") обозначают производные справедливой цены опциона по различным характеристикам, от которых эта справедливая цена зависит. Все эти характеристики считаются из расчета на один опцион. Для подсчета соответствующей характеристики портфеля нужно перемножить значения греков на объемы позиций и затем сложить полученные значения.

  1. Дельта – производная по цене базисного актива опциона. Эта характеристика определяет, на сколько изменится справедливая цена одного опциона при увеличении цены базисного актива на единицу (в данном случае, на 1 рубль). В данном случае имеется в виду увеличение на 1 рубль цены одного фьючерса, если используется формула Блека, или цены 1 контрактного лота акций (числа акций, составляющих специфицированный биржей фьючерсный контракт), если используется формула Блека-Шоулса. Основное использование дельты – это создание дельта-нейтральных портфелей (портфелей с нулевым дельта), которые отличаются тем, что их стоимость не изменится при небольшом изменении цены базисного актива.
  2. Гамма – это производная дельты по цене базисного актива опциона (или вторая производная справедливой стоимости опциона по цене базисного актива). Эта характеристика определяет то, насколько изменится дельта при увеличении цены базисного актива на 1 рубль. Гамма характеризует, насколько дельта-нейтральность портфеля является устойчивой по отношению к изменению цены базисного актива, т.е. насколько близкое к нулю значение дельты останется таковым при изменении цены базисного актива.
  3. Вега – это производная по волатильности (при измерении волатильности в процентах). Эта величина характеризует устойчивость по отношению к изменению волатильности и определяет, насколько изменится справедливая цена опциона при увеличении годовой волатильности на 1 процент.
  4. Ро – это производная по безрисковой ставке (при измерении безрисковой ставки в процентах). Эта величина характеризует устойчивость по отношению к изменению безрисковой ставки и определяет, насколько изменится справедливая цена опциона при увеличении безрисковой ставки на 1 процент.
  5. Тета – это производная по времени до истечения срока опциона (при измерении времени в рабочих днях). Эта величина характеризует поведение по отношению к изменению времени до экспирации и определяет, насколько увеличится справедливая цена опциона при уменьшении этого времени на 1 рабочий день.